コガネブログ

平日更新を目標にUnityやC#、Visual Studioなどのゲーム開発アレコレを書いていきます

【Unity】NDK rXXXX is incompatible with IL2CPP. IL2CPP requires rYYYY.

はじめに

f:id:baba_s:20180912101238p:plain

Invalid NDK version
NDK rXXXX is incompatible with IL2CPP. IL2CPP requires rYYYY.

Unity で Android 向けの IL2CPP ビルドを行う時に上記の警告が発生した場合、
Android NDK のバージョンが正しくないので、
最新の Android NDK をダウンロードする必要があります

手順

f:id:baba_s:20180912101238p:plain

上記のダイアログが表示されたら「Download」ボタンを押します
「android-ndk-rXXXX-YYYY.zip」をダウンロードしたら展開します
そして、フォルダ選択ダイアログで、展開したフォルダ内に存在する
「android-ndk-rXXXX」フォルダを選択します